Opened 6 years ago

Closed 6 years ago

#89 closed defect (fixed)

Corrupted image when saving in c64 format

Reported by: dusan.milivojevic@… Owned by: pulkomandy
Priority: major Milestone: 2.6
Component: GrafX2 Version: 2.5
Keywords: c64 format Cc:

Description

When saving image in c64 format, sometimes some parts of the image get corrupted (entire pixel block (per char) is in the wrong color).

Please check the attached test file!

When saving the example gif in the c64 format, image will get corrupted.

Attachments (1)

c64test.zip (12.6 KB ) - added by dusan.milivojevic@… 6 years ago.
Example images that show corruption when saving to c64 format

Download all attachments as: .zip

Change History (8)

by dusan.milivojevic@…, 6 years ago

Attachment: c64test.zip added

Example images that show corruption when saving to c64 format

comment:1 by Thomas Bernard, 6 years ago

What's is the version of GrafX2 you are using ? Please give the whole version as given in the "statistics" window.

Because I tried to reproduce (loaded the .gif, saved as .c64 multicolor with load address at $6000
and my file is correct...)

comment:2 by Thomas Bernard, 6 years ago

Im' not sure but that could be that commit where the bug was fixed : https://gitlab.com/GrafX2/grafX2/commit/06f88093374e54a58f85f704cba1a2d2166be914

comment:3 by dusan.milivojevic@…, 6 years ago

As for what version I'm using, the example files I sent were saved from
grafx2-2.5.1949-HEAD-win32
and it's exactly the same as in previous version I used which was
grafx2-2.3.1781-win32

How can I get the version with the fix if it's not the above mentioned?

comment:4 by Thomas Bernard, 6 years ago

http://grafx2.tk/ "Download" section. Get the "Nightly build"

comment:5 by Thomas Bernard, 6 years ago

you can also download all the automatic builds here : https://gitlab.com/GrafX2/grafX2/pipelines

comment:6 by dusan.milivojevic@…, 6 years ago

YES! I tried grafx2-win32-2.6wip2326-win32 version and it works ok! Now waiting for the official 2.6 version.

comment:7 by Thomas Bernard, 6 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.